Failover 2 WAN Mikrotik

Si se tienen dos servicios de internet, se puede configurar un Failover en Mikrotik, cuando falle el principal, pueda subir el de backup:

Si las interfaces WAN están configuradas por DHCP se debe deshabilitar Add Default Route para configurarlas manualmente.

Configurar 3 rutas

La primera ruta es la WAN1 por defecto, importante que el comentario sea Default Route
El gateway del internet de backup se configura con distancia 2 y comentario Backup Route
La última ruta con comentario Check es la encargada de supervisar si a traves de la ruta 1 hay internet, haciendo ping a la dirección ip 208.67.222.222

Abrir la herramienta Netwatch

Configurar el Host 208.67.222.222, Netwatch se encaragá de hacerle ping a ésta ip.

Si no hay respuesta de ping a esta ip por la WAN1, ejecutará el comando que se encuentre en Down y mantendrá el ping hasta que obtenga respuesta, entonces ejecutará el comando que se encuentre en Up.

Cuando no haya respuesta del ping ejecutará el script down
Cuando haya respuesta del ping ejecutará el script up

Abrir Scripts

Crear un nuevo script llamado down

Este script ejecuta 3 comandos:

  1. Envía un mensaje al log.
  2. Actualiza la distancia de la ruta por defecto.
  3. Envía una alerta a Telegram. (opcional)
:log warning "$[/system identity get name] Internet DOWN"
/ip route set [find comment="Default Route"] distance=3
/tool fetch url="https://api.telegram.org/botabcde123456/sendMessage\?chat_id=-12345678&text=$[/system identity get name] Internet DOWN - $[/system clock get date] $[/system clock get time] " keep-result=no
Se configura también el script up
:log warning "$[/system identity get name] Internet UP"
/ip route set [find comment="Default Route"] distance=1
/tool fetch url="https://api.telegram.org/botabcdef12345678/sendMessage\?chat_id=-12345678&text=$[/system identity get name] Internet UP - $[/system clock get date] $[/system clock get time] " keep-result=no

Listo.

Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

9 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
Mike Kunta

No esta mal, pero cuando el mikrotik obtiene las ip publica no servira.
Pero si las dos conexiones tienen un dmz hacia el mikrotik si servira

everardo garcia

en que momento se habilita el backup Route porque con distance=2 no me pasa internet

schubert acosta

me anda.
gracias !!!!

Guaro

Como hago para usar este script si tengo dos ISPs Dinamicos?

Javier

Funciona a la perfección, muchas gracias por compartir, me fue muy útil.

Miguel

Gracias, me funcionó a la perfección, en mi caso el MK coge las IPs por DHCP.

Kevin

Como haces con el nat? Tengo dos ip publicas pero tengo nateada a la red privada. Hay que tener los dos NAT habilitados siempre?