Skip to content
Code and Bytes Code and Bytes

Code and Bytes
Code and Bytes

Usar yum install en Elastix 4

Posted on 25 July, 202125 July, 2021

Luego de querer instalar java-1.8.0-openjdk me aparecía el siguiente error en Elastix 4:

14: curl#6 - "Could not resolve host: mirror.elastix.org; Name or service not known" 

Esto se debe a que los repositorios ya no se encuentran disponibles.

Loaded plugins: fastestmirror
LowayResearch                                                                                                     | 3.0 kB  00:00:00     
Could not retrieve mirrorlist http://mirror.elastix.org/?release=4&arch=x86_64&repo=commercial_addons error was
14: curl#6 - "Could not resolve host: mirror.elastix.org; Name or service not known"


 One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: commercial-addons/x86_64

Para solucionarlo tuve que cambiar los nombres de los archivos que continenen los repositorios para que estos no sean leídos.

cd /etc/yum.repos.d/
mv commercial-addons.repo commercial-addons.repo.bk
mv elastix.repo elastix.repo.bk
mv epel.repo epel.repo.bk

Luego de esto ya me permite instalar java pero hay que colocarle –nogpg al final

yum install java-1.8.0-openjdk --nogpg
Asterisk

Post navigation

Previous post
Next post

Related Posts

Samba en Issabel

Posted on 14 March, 20189 April, 2020

yum install samba samba-client samba-common nano /etc/samba/smb.conf Dentro de global [global] map to guest = bad user /bin/systemctl restart smb.service Luego se crean los puertos y se habilitan en el Firwall de Issabel

Read More

SOLVED: CDR Report Empty and Calls Recordings in Asterisk

Posted on 25 January, 202025 January, 2020

Edit cdr_adaptive_odbc.confnano /etc/asterisk/cdr_adaptive_odbc.conf Add [adaptive_connection] connection=asteriskcdrdb table=cdr usegmtime=no alias start => calldate unaswered= yes congestion= yes and reload

Read More
Asterisk

Configurar ext de Callcentric en Asterisk

Posted on 13 September, 202113 September, 2021

Recientemente adquirí un número de Estados Unidos, a continuación muestro cómo configurarlo en Asterisk: 1. Configurar la troncal Editar el archivo sip_custom.conf y agregar:

Read More

Leave a Reply Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Buscar

Categorias

  • AI (2)
  • Asterisk (9)
  • Bases de datos (1)
  • DevOps (4)
  • Git (2)
  • HTML (1)
  • Laravel (6)
  • Linux (67)
  • MCP Server (1)
  • Mikrotik (3)
  • MySQL (5)
  • n8n (1)
  • Personal (4)
  • PHP (15)
  • Python (2)
  • Software recomendado (1)
  • Tips (1)
  • VSCode (4)
  • vTiger (4)
  • Windows (10)
  • Wordpress (4)
©2026 Code and Bytes | WordPress Theme by SuperbThemes