Skip to content
Code and Bytes Code and Bytes

Code and Bytes
Code and Bytes

Instalar dropbox desde línea de comandos en Debian

Posted on 24 February, 201312 June, 2015

1. Desde el home del usuario (preferiblemente que no sea el root) ejecutar:

wget -O dropbox.tar.gz "https://www.dropbox.com/download?plat=lnx.x86" --no-check-certificate

Con ésto descargamos el archivo dropbox.tar.gz para luego extraerlo:

tar -xvzf dropbox.tar.gz

Ejecutamos dropbxd:

.dropbox-dist/dropboxd

Nos da un link al cual debemos ingresar con la cuenta de dropbox, luego aparece:

Client successfully linked, Welcome Jaime!

Cerramos el proceso con Ctrl X y vemos que se ha creado la carpeta Dropbox en nuestro home, ahora se debe descargar el otro script que le da mas funcionalidad:

wget -O ~/dropbox.py "http://www.dropbox.com/download?dl=packages/dropbox.py" --no-check-certificate

y le damos permisos de ejecución:

chmod 755 ~/dropbox.py

Ejecutamos dropbox.py:

osmon@osmonB:~/Dropbox$ ~/dropbox.py start
Starting Dropbox...Dropbox isn't running!
Done!

Ahora vamos a excluir de la sincronización algunas carpetas, nos ubicamos en la carpeta Dropbox y de esta forma excluimos ~/dropbox.py exclude add [directory] [directory] [directory]

~/dropbox.py exclude add carpeta1 carpeta2 carpeta3

Si al ejecutar el comando aparece este error:

-bash: /home/osmon/dropbox.py: /usr/bin/python: bad interpreter: No such file or directory

Es porque no tenemos instalado python para poder ejecutar el script. Se instala con el usuario root

apt-get install python

Listo, ya estamos sincronizando dropbox.

Fuente

Linux clidebiandropboxterminalubuntu

Post navigation

Previous post
Next post

Related Posts

Solución: apache2 could not open error log file /var/log/apache2/error.log

Posted on 3 March, 201323 December, 2014

Si al tratar de subir el servicio apache2 aparece este mensaje: Starting web server: apache2(2)No such file or directory: apache2: could not open error log file /var/log/apache2/error.log. Unable to open logs Action ‘start’ failed. The Apache error log may have more information. failed!

Read More

gpg: failed to start the dirmngr ‘/usr/bin/dirmngr’: No such file or directory

Posted on 31 March, 201931 March, 2019

Al querer agregar un repositorio aparece el error: Acompañado de: Para solucionarlo hay que instalar el paquete dirmgr: y listo.

Read More

Crear enlaces simbólicos en apache

Posted on 9 September, 201426 June, 2015

Para crear enlaces simbolicos en apache apuntando a Dropbox debemos realizar los siguientes pasos. Primero hay que recordar que el contenido del sitio web se almacena en : /var/www/html

Read More

Leave a Reply Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Buscar

Categorias

  • AI (2)
  • Asterisk (9)
  • Bases de datos (1)
  • DevOps (4)
  • Git (2)
  • HTML (1)
  • Laravel (6)
  • Linux (67)
  • MCP Server (1)
  • Mikrotik (3)
  • MySQL (5)
  • n8n (1)
  • Personal (4)
  • PHP (15)
  • Python (2)
  • Software recomendado (1)
  • Tips (1)
  • VSCode (4)
  • vTiger (4)
  • Windows (10)
  • Wordpress (4)
©2026 Code and Bytes | WordPress Theme by SuperbThemes